summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/krb5/krb5-0.3.0-r1.ebuild')
-rw-r--r--dev-python/krb5/krb5-0.3.0-r1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/krb5/krb5-0.3.0-r1.ebuild b/dev-python/krb5/krb5-0.3.0-r1.ebuild
deleted file mode 100644
index 432e99c1de1b..000000000000
--- a/dev-python/krb5/krb5-0.3.0-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Kerberos API bindings for Python"
-HOMEPAGE="https://pypi.org/project/krb5/ https://github.com/jborean93/pykrb5"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- virtual/krb5
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? ( dev-python/k5test[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- # Needed for Python 3.11, can drop in next release (after 0.3.0)
- cd src/krb5 || die
- rm _*.c || die
- cythonize -f -3 *.pyx || die
-}