summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/liblarch')
-rw-r--r--dev-python/liblarch/Manifest1
-rw-r--r--dev-python/liblarch/liblarch-2.1.0.ebuild28
-rw-r--r--dev-python/liblarch/metadata.xml21
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/liblarch/Manifest b/dev-python/liblarch/Manifest
new file mode 100644
index 000000000000..40d53a519aba
--- /dev/null
+++ b/dev-python/liblarch/Manifest
@@ -0,0 +1 @@
+DIST liblarch-2.1.0.tar.gz 26829 SHA256 f55b8ce2c6350b614f46acf826c323b03bd64890288dd25b31cda3ccdb59d49b SHA512 fd6a6c48142e434f49fb49d9dee874b88f013775c280dd2dc929ed5fff4df7bd3743bf915b09dac4329f894cac24e466d78366a072136de389725bc5ed985ec1 WHIRLPOOL b2e34e15d5dd523597cc369fbfec6c02a8785b34c6fec1035a0995714aecde2c4dfe92ead1b1b60cfed81a725f85af7e604eda25fa46028ab36d0b8e73bd8485
diff --git a/dev-python/liblarch/liblarch-2.1.0.ebuild b/dev-python/liblarch/liblarch-2.1.0.ebuild
new file mode 100644
index 000000000000..f8d30a58f559
--- /dev/null
+++ b/dev-python/liblarch/liblarch-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to handle directed acyclic graphs"
+HOMEPAGE="http://live.gnome.org/liblarch"
+SRC_URI="http://gtg.fritalk.com/publique/gtg.fritalk.com/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+# This is what should be run if tarball included testsuite
+#python_test() {
+# ${PYTHON} "${S}"/run-tests
+#}
diff --git a/dev-python/liblarch/metadata.xml b/dev-python/liblarch/metadata.xml
new file mode 100644
index 000000000000..3d3428dce28d
--- /dev/null
+++ b/dev-python/liblarch/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>eva@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>leio@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>steev@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Liblarch is a python library built to easily handle data structure such are lists, trees and directed acyclic graphs (tree where nodes can have multiple parents). There's also a liblarch-gtk binding that will allow you to use your data structure in a Gtk.Treeview.
+
+ Liblarch supports multiple views of one data structure and complex filtering. That way, you have a clear separation between your data themselves (Model) and how they are displayed (View).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">liblarch/liblarch</remote-id>
+ </upstream>
+</pkgmetadata>