summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lit/lit-8.0.1.ebuild')
-rw-r--r--dev-python/lit/lit-8.0.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/lit/lit-8.0.1.ebuild b/dev-python/lit/lit-8.0.1.ebuild
deleted file mode 100644
index 03682e862735..000000000000
--- a/dev-python/lit/lit-8.0.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1 multiprocessing
-
-MY_P=llvm-${PV/_/}.src
-DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://github.com/llvm/llvm-project/releases/download/llvmorg-${PV}/${MY_P}.tar.xz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${MY_P}/utils/lit
-
-# Tests require 'FileCheck' and 'not' utilities (from llvm)
-DEPEND="
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm )"
-
-# TODO: move the manpage generation here (from sys-devel/llvm)
-
-src_unpack() {
- einfo "Unpacking parts of ${MY_P}.tar.xz ..."
- tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/lit" || die
-}
-
-python_test() {
- ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
- -vv tests || die
-}