summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lp_solve')
-rw-r--r--dev-python/lp_solve/Manifest1
-rw-r--r--dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch50
-rw-r--r--dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild48
-rw-r--r--dev-python/lp_solve/metadata.xml11
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/lp_solve/Manifest b/dev-python/lp_solve/Manifest
new file mode 100644
index 000000000000..294a0bf207bb
--- /dev/null
+++ b/dev-python/lp_solve/Manifest
@@ -0,0 +1 @@
+DIST lp_solve_5.5.2.0_Python_source.tar.gz 58017 SHA256 79683bc262e9da5b2fa7338ba190a9cd10559b9f2dbcb8f3bf07e2a81083ac51 SHA512 eaf732a1f3497c27e40a037be21b2e1552c3aec6cc7801c47d68a439be556ac45c2f1bb90e403d1a4b8bd42b0be0b323b8c3364363e6d51ecb0ad0934902444c WHIRLPOOL c40af8a5abacc98981a723d3d988e8921c35f988261d6a55da3f635aa920150b96186e35de4dcc3fe452b920041a161a24e40f5b5ec59db5a1ccb303967ccd7b
diff --git a/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch b/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch
new file mode 100644
index 000000000000..a28b8179d261
--- /dev/null
+++ b/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch
@@ -0,0 +1,50 @@
+--- setup.py.orig 2012-01-07 20:27:45.072840503 +0000
++++ setup.py 2012-01-07 20:24:22.127570128 +0000
+@@ -1,26 +1,25 @@
+ from distutils.core import setup, Extension
+ from os import getenv
+ import sys
+-import os
+-p = sys.prefix
+-NUMPYPATH = '.'
+-if os.path.isdir(p + '/include/numpy'):
+- NUMPY = 'NUMPY'
+-elif os.path.isdir(p + '/Lib/site-packages/numpy/core/include/numpy'):
+- NUMPY = 'NUMPY'
+- NUMPYPATH = p + '/Lib/site-packages/numpy/core/include'
+-else:
++import os, os.path
++
++try:
++ import numpy
++ NUMPY = 'NUMPY'
++ NUMPYPATH = numpy.get_include()
++except:
+ NUMPY = 'NONUMPY'
+-print 'numpy: ' + NUMPY
++ NUMPYPATH = '.'
++
+ windir = getenv('windir')
+ if windir == None:
+ WIN32 = 'NOWIN32'
+- LPSOLVE55 = '../../lpsolve55/bin/ux32'
++ LPSOLVEINC = os.path.join(sys.prefix,'include','lpsolve')
+ else:
+ WIN32 = 'WIN32'
+ LPSOLVE55 = '../../lpsolve55/bin/win32'
+ setup (name = "lpsolve55",
+- version = "5.5.0.9",
++ version = "5.5.2.0",
+ description = "Linear Program Solver, Interface to lpsolve",
+ author = "Peter Notebaert",
+ author_email = "lpsolve@peno.be",
+@@ -29,8 +28,7 @@
+ ext_modules = [Extension("lpsolve55",
+ ["lpsolve.c", "hash.c", "pythonmod.c"],
+ define_macros=[('PYTHON', '1'), (WIN32, '1'), ('NODEBUG', '1'), ('DINLINE', 'static'), (NUMPY, '1'), ('_CRT_SECURE_NO_WARNINGS', '1')],
+- include_dirs=['../..', NUMPYPATH],
+- library_dirs=[LPSOLVE55],
++ include_dirs=[LPSOLVEINC, NUMPYPATH],
+ libraries = ["lpsolve55"])
+ ]
+ )
diff --git a/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild b/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild
new file mode 100644
index 000000000000..4941a9c6d42a
--- /dev/null
+++ b/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python wrappers for lpsolve linear programming library"
+HOMEPAGE="http://lpsolve.sourceforge.net/5.5/Python.htm"
+SRC_URI="mirror://sourceforge/lpsolve/${PN}_${PV}_Python_source.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-mathematics/lpsolve"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}_5.5/extra/Python/"
+
+PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv ex*py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" lpdemo.py || die
+}
+
+python_install_all() {
+ dodoc changes
+ use doc && dohtml Python.htm
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/lp_solve/metadata.xml b/dev-python/lp_solve/metadata.xml
new file mode 100644
index 000000000000..71f0f27b3d6f
--- /dev/null
+++ b/dev-python/lp_solve/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+ Python wrapper modules for the linear programming library lpsolve.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">lpsolve</remote-id>
+ </upstream>
+</pkgmetadata>