summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lz4/lz4-0.6.1.ebuild')
-rw-r--r--dev-python/lz4/lz4-0.6.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/lz4/lz4-0.6.1.ebuild b/dev-python/lz4/lz4-0.6.1.ebuild
new file mode 100644
index 000000000000..0359e1a6c2fc
--- /dev/null
+++ b/dev-python/lz4/lz4-0.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.python.org/pypi/lz4 https://github.com/steeve/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed \
+ -e '/nose/d' \
+ -e 's:"-O4"::g' \
+ -i setup.py || die
+}