summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/m2secret/m2secret-0.1.1-r1.ebuild')
-rw-r--r--dev-python/m2secret/m2secret-0.1.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/m2secret/m2secret-0.1.1-r1.ebuild b/dev-python/m2secret/m2secret-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..11b13f21c42e
--- /dev/null
+++ b/dev-python/m2secret/m2secret-0.1.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Encryption and decryption module and CLI utility"
+HOMEPAGE="http://www.heikkitoivonen.net/m2secret http://pypi.python.org/pypi/m2secret"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/m2crypto-0.18[${PYTHON_USEDEP}]"