summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mccabe/mccabe-0.3.1.ebuild')
-rw-r--r--dev-python/mccabe/mccabe-0.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/mccabe/mccabe-0.3.1.ebuild b/dev-python/mccabe/mccabe-0.3.1.ebuild
new file mode 100644
index 000000000000..11d40045b229
--- /dev/null
+++ b/dev-python/mccabe/mccabe-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="a plugin for flake8"
+HOMEPAGE="https://github.com/flintwork/mccabe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=dev-python/pep8-1.4.3[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test_mccabe.py || die
+}