summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/munch/munch-2.5.0-r1.ebuild')
-rw-r--r--dev-python/munch/munch-2.5.0-r1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/munch/munch-2.5.0-r1.ebuild b/dev-python/munch/munch-2.5.0-r1.ebuild
deleted file mode 100644
index 2631cbbc637a..000000000000
--- a/dev-python/munch/munch-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A dot-accessible dictionary (a la JavaScript objects)"
-HOMEPAGE="https://github.com/Infinidat/munch"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~x64-macos"
-SLOT="0"
-
-BDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- test? ( >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )
-"
-
-PATCHES=(
- "${FILESDIR}/munch-2.5.0-revert-pbr.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- sed -i "s:__version__:'${PV}':" setup.py || die
-}