summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/munkres/munkres-1.0.5.4-r2.ebuild')
-rw-r--r--dev-python/munkres/munkres-1.0.5.4-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/munkres/munkres-1.0.5.4-r2.ebuild b/dev-python/munkres/munkres-1.0.5.4-r2.ebuild
new file mode 100644
index 000000000000..4dbe68e0abf9
--- /dev/null
+++ b/dev-python/munkres/munkres-1.0.5.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module implementing munkres algorithm for the Assignment Problem"
+HOMEPAGE="http://pypi.python.org/pypi/munkres/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+python_test() {
+ "${PYTHON}" "${PN}.py" || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ use doc && dohtml -r html/
+}