summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbconvert/nbconvert-6.3.0-r1.ebuild')
-rw-r--r--dev-python/nbconvert/nbconvert-6.3.0-r1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/nbconvert/nbconvert-6.3.0-r1.ebuild b/dev-python/nbconvert/nbconvert-6.3.0-r1.ebuild
deleted file mode 100644
index 80fa64db3799..000000000000
--- a/dev-python/nbconvert/nbconvert-6.3.0-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Converting Jupyter Notebooks"
-HOMEPAGE="https://nbconvert.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 hppa ~ia64 ppc ~ppc64 ~riscv ~s390 ~sparc x86"
-
-RDEPEND="
- dev-python/bleach[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- >=dev-python/entrypoints-0.2.2[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- dev-python/jupyterlab_pygments[${PYTHON_USEDEP}]
- >=dev-python/mistune-0.7.4[${PYTHON_USEDEP}]
- dev-python/nbclient[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
-"
-# Skip inkscape on hppa b/c tests should skip it gracefully if not around
-# It's a heavy dependency.
-BDEPEND="
- test? (
- dev-python/pebble[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-4.2[${PYTHON_USEDEP}]
- !hppa? ( media-gfx/inkscape )
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- mkdir -p "${HOME}/.local" || die
- cp -r share "${HOME}/.local/" || die
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Missing pyppeteer for now
- # TODO: Doesn't skip?
- nbconvert/exporters/tests/test_webpdf.py
- # Needs pyppeteer too
- 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
- )
-
- distutils_install_for_testing bdist_egg
- cd "${TEST_DIR}"/lib || die
- epytest --pyargs nbconvert
-}
-
-pkg_postinst() {
- if ! has_version app-text/pandoc ; then
- einfo "Pandoc is required for converting to formats other than Python,"
- einfo "HTML, and Markdown. If you need this functionality, install"
- einfo "app-text/pandoc."
- fi
-}