summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/neovim-remote/neovim-remote-9999.ebuild')
-rw-r--r--dev-python/neovim-remote/neovim-remote-9999.ebuild34
1 files changed, 25 insertions, 9 deletions
diff --git a/dev-python/neovim-remote/neovim-remote-9999.ebuild b/dev-python/neovim-remote/neovim-remote-9999.ebuild
index 3d18a58845ba..c4c5cdfd52ef 100644
--- a/dev-python/neovim-remote/neovim-remote-9999.ebuild
+++ b/dev-python/neovim-remote/neovim-remote-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7,8} )
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -10,17 +12,31 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
fi
DESCRIPTION="A tool that helps control neovim processes"
-HOMEPAGE="https://github.com/mhinz/neovim-remote"
+HOMEPAGE="
+ https://github.com/mhinz/neovim-remote/
+ https://pypi.org/project/neovim-remote/
+"
+
LICENSE="MIT"
SLOT="0"
RDEPEND="
dev-python/pynvim[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-editors/neovim
+ )
+"
+
+distutils_enable_tests pytest