summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/notify2/notify2-0.3.1-r2.ebuild')
-rw-r--r--dev-python/notify2/notify2-0.3.1-r2.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/notify2/notify2-0.3.1-r2.ebuild b/dev-python/notify2/notify2-0.3.1-r2.ebuild
deleted file mode 100644
index 2e66f17f4e27..000000000000
--- a/dev-python/notify2/notify2-0.3.1-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Python interface to DBus notifications"
-HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="examples"
-
-RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- dev-python/pygobject[${PYTHON_USEDEP}]
- sys-apps/dbus[X]
- x11-libs/gdk-pixbuf[introspection]
- virtual/notification-daemon
-)"
-
-distutils_enable_tests unittest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_install_all() {
- if use examples; then
- rm examples/notify2.py || die
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}