summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oct2py/oct2py-4.0.6.ebuild')
-rw-r--r--dev-python/oct2py/oct2py-4.0.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/oct2py/oct2py-4.0.6.ebuild b/dev-python/oct2py/oct2py-4.0.6.ebuild
new file mode 100644
index 000000000000..cafb9f92a0ff
--- /dev/null
+++ b/dev-python/oct2py/oct2py-4.0.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="http://blink1073.github.io/oct2py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ dev-python/octave_kernel[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.17[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )
+"
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ py.test -v -v || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}