summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-cache/oslo-cache-1.30.3-r1.ebuild')
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.30.3-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/oslo-cache/oslo-cache-1.30.3-r1.ebuild b/dev-python/oslo-cache/oslo-cache-1.30.3-r1.ebuild
deleted file mode 100644
index a185fd034056..000000000000
--- a/dev-python/oslo-cache/oslo-cache-1.30.3-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Caching around dogpile.cache"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/patches/bug-681012.patch"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${DISTDIR}/bug-681012.patch"
-)
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}