summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/osprofiler')
-rw-r--r--dev-python/osprofiler/Manifest1
-rw-r--r--dev-python/osprofiler/osprofiler-3.4.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/osprofiler/Manifest b/dev-python/osprofiler/Manifest
index d217d8eb0aad..6d1be18261f2 100644
--- a/dev-python/osprofiler/Manifest
+++ b/dev-python/osprofiler/Manifest
@@ -1 +1,2 @@
DIST osprofiler-2.6.0.tar.gz 80518 BLAKE2B bc45f9bf3378b75a8c702ab1bf9ba40e9f6d77bba808882c7c504adb4f1c295449ab2cc19d128cdec7ebb3120a3d0c49eb77e1769625bafa216e32b3304c6f1e SHA512 3c911961b3107f28bc7b625738d6afb0098d87b891603d1a41be5cfea2b21eb0a3358f3f2fc5cfa0f9b32287f59d732c4ade8ae3436fe46095fa220b5bfb7a15
+DIST osprofiler-3.4.0.tar.gz 86842 BLAKE2B 78a679424023f7cd20a0c6c5825747e3c108e977b44985e2f106b8e82d9cfb44f84b3662df531c64cf09fd4ce313c8a457b803ca820291d58f4f2bacb51eff81 SHA512 d88c0c68eee693a799f4e52a447dd7a4b79f7eddeb1c82bf41cdf3be6457c1b1116b6caa19530de4df376a1cbc26f4094835c3ef7110016d3d9ba989f8e8e41c
diff --git a/dev-python/osprofiler/osprofiler-3.4.0.ebuild b/dev-python/osprofiler/osprofiler-3.4.0.ebuild
new file mode 100644
index 000000000000..93034731fcd2
--- /dev/null
+++ b/dev-python/osprofiler/osprofiler-3.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Profiler Library"
+HOMEPAGE="https://launchpad.net/osprofiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
+"