summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/outcome/outcome-1.2.0.ebuild')
-rw-r--r--dev-python/outcome/outcome-1.2.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/outcome/outcome-1.2.0.ebuild b/dev-python/outcome/outcome-1.2.0.ebuild
deleted file mode 100644
index e63ca640f474..000000000000
--- a/dev-python/outcome/outcome-1.2.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Capture the outcome of Python function calls"
-HOMEPAGE="
- https://github.com/python-trio/outcome/
- https://pypi.org/project/outcome/
-"
-SRC_URI="
- https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio