summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/passlib/passlib-1.6.5-r1.ebuild')
-rw-r--r--dev-python/passlib/passlib-1.6.5-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/passlib/passlib-1.6.5-r1.ebuild b/dev-python/passlib/passlib-1.6.5-r1.ebuild
new file mode 100644
index 000000000000..2a10e689ca87
--- /dev/null
+++ b/dev-python/passlib/passlib-1.6.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Password hashing framework supporting over 20 schemes"
+HOMEPAGE="https://bitbucket.org/ecollins/passlib/wiki/Home/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+IUSE="test doc"
+
+RDEPEND="dev-python/bcrypt[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
+}