summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/peewee/peewee-3.14.4.ebuild')
-rw-r--r--dev-python/peewee/peewee-3.14.4.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/peewee/peewee-3.14.4.ebuild b/dev-python/peewee/peewee-3.14.4.ebuild
deleted file mode 100644
index 10d743299d6b..000000000000
--- a/dev-python/peewee/peewee-3.14.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="Small Python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? ( dev-python/psycopg[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- "${EPYTHON}" ./runtests.py -v 2 || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && DOCS=( examples/ )
- distutils-r1_python_install_all
-}