summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pip-run/pip-run-8.8.1.ebuild')
-rw-r--r--dev-python/pip-run/pip-run-8.8.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pip-run/pip-run-8.8.1.ebuild b/dev-python/pip-run/pip-run-8.8.1.ebuild
deleted file mode 100644
index 4ce3a99ddf97..000000000000
--- a/dev-python/pip-run/pip-run-8.8.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Install packages and run Python with them"
-HOMEPAGE="
- https://github.com/jaraco/pip-run/
- https://pypi.org/project/pip-run/
-"
-SRC_URI="
- https://github.com/jaraco/pip-run/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/autocommand[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pygments[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_IGNORE=(
- # Needs network access, and another test dep nbformat
- pip_run/tests/test_scripts.py
-)
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}