summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pipenv/pipenv-8.3.2.ebuild')
-rw-r--r--dev-python/pipenv/pipenv-8.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pipenv/pipenv-8.3.2.ebuild b/dev-python/pipenv/pipenv-8.3.2.ebuild
new file mode 100644
index 000000000000..dd7ad3f7639f
--- /dev/null
+++ b/dev-python/pipenv/pipenv-8.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Development Workflow for Humans."
+HOMEPAGE="https://github.com/kennethreitz/pipenv https://pypi.python.org/pypi/pipenv"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# not completely packed
+# requires networking
+RESTRICT="test"
+
+python_test() {
+ py.test -v -v || die
+}