summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pipenv/pipenv-9.0.0-r1.ebuild')
-rw-r--r--dev-python/pipenv/pipenv-9.0.0-r1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pipenv/pipenv-9.0.0-r1.ebuild b/dev-python/pipenv/pipenv-9.0.0-r1.ebuild
deleted file mode 100644
index 29826767a98c..000000000000
--- a/dev-python/pipenv/pipenv-9.0.0-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Development Workflow for Humans"
-HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/flake8-3.0.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
- >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
- >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-# not completely packed
-# requires networking
-RESTRICT="test"
-
-python_test() {
- py.test -v -v || die
-}