summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch')
-rw-r--r--dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch b/dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch
new file mode 100644
index 000000000000..f3e7c8f0fd70
--- /dev/null
+++ b/dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch
@@ -0,0 +1,26 @@
+From 8fd388dd17f8bfa7df62cbea86d077c1d0d0cb66 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 10 Apr 2021 10:49:57 +0200
+Subject: [PATCH] [Gentoo-specific] clear swig deprecation warning
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 14f0f1b..b1f9a8f 100755
+--- a/setup.py
++++ b/setup.py
+@@ -144,7 +144,7 @@ class pivy_build(build):
+ SWIG = ((sys.platform == "win32" and "swig.exe") or "swig")
+
+ SWIG_SUPPRESS_WARNINGS = "-w302,306,307,312,314,325,361,362,467,389,503,509,510"
+- SWIG_PARAMS = "-c++ -python -includeall -modern -D__PIVY__ " + \
++ SWIG_PARAMS = "-c++ -python -includeall -D__PIVY__ " + \
+ "-I. -Ifake_headers -I\"%s\" %s -o %s_wrap.cpp " + \
+ "interfaces" + os.sep + "%s.i"
+ if sys.version_info.major >= 3:
+--
+2.31.1
+