summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ply/ply-3.11.ebuild')
-rw-r--r--dev-python/ply/ply-3.11.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/ply/ply-3.11.ebuild b/dev-python/ply/ply-3.11.ebuild
deleted file mode 100644
index b9c1bcae57eb..000000000000
--- a/dev-python/ply/ply-3.11.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Lex-Yacc library"
-HOMEPAGE="http://www.dabeaz.com/ply/ https://pypi.org/project/ply/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( ANNOUNCE CHANGES TODO )
-
-PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
-
-python_test() {
- cp -r -l test "${BUILD_DIR}"/ || die
- cd "${BUILD_DIR}"/test || die
-
- # Checks for pyc/pyo files
- local -x PYTHONDONTWRITEBYTECODE=
-
- local t
- for t in testlex.py testyacc.py; do
- "${EPYTHON}" "${t}" -v || die "${t} fails with ${EPYTHON}"
- done
-}
-
-python_install_all() {
- local HTML_DOCS=( doc/. )
- use examples && dodoc -r example
- distutils-r1_python_install_all
-}