summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/podman-py/podman-py-3.2.1.ebuild')
-rw-r--r--dev-python/podman-py/podman-py-3.2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/podman-py/podman-py-3.2.1.ebuild b/dev-python/podman-py/podman-py-3.2.1.ebuild
new file mode 100644
index 000000000000..c0d18e6cc5dc
--- /dev/null
+++ b/dev-python/podman-py/podman-py-3.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.2[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit
+}