summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/process-tests')
-rw-r--r--dev-python/process-tests/Manifest1
-rw-r--r--dev-python/process-tests/metadata.xml13
-rw-r--r--dev-python/process-tests/process-tests-1.1.0.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/process-tests/Manifest b/dev-python/process-tests/Manifest
new file mode 100644
index 000000000000..676667885797
--- /dev/null
+++ b/dev-python/process-tests/Manifest
@@ -0,0 +1 @@
+DIST process-tests-1.1.0.tar.gz 5450 SHA256 38cccf8f9867c78aa18edf9ec40ca87ff0994af2d588ebf482504873557489fe SHA512 0fcb9a0f1e01bd800a72d0c0f946e58e76d01923abc3731c4cb7f589cc8655d6ad4440c339d497f388c009fd569e547c183f024fd0768a2d23afa558e09156ac WHIRLPOOL da4df1eb80a34701df81c355f6e23883e7563417ea428f0d873bdecf3a506bcb3a62b0f17d73020d45bd92eec5c8df33a68e0ffc8b948cfb25ff47222769d36e
diff --git a/dev-python/process-tests/metadata.xml b/dev-python/process-tests/metadata.xml
new file mode 100644
index 000000000000..9ff7a6400d92
--- /dev/null
+++ b/dev-python/process-tests/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pxml</remote-id>
+ <remote-id type="github">metagriffin/pxml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/process-tests/process-tests-1.1.0.ebuild b/dev-python/process-tests/process-tests-1.1.0.ebuild
new file mode 100644
index 000000000000..75f622ca6679
--- /dev/null
+++ b/dev-python/process-tests/process-tests-1.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for testing processes"
+HOMEPAGE="https://github.com/ionelmc/python-process-tests https://pypi.python.org/pypi/process-tests"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "