summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyClamd/pyClamd-0.4.0-r1.ebuild')
-rw-r--r--dev-python/pyClamd/pyClamd-0.4.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyClamd/pyClamd-0.4.0-r1.ebuild b/dev-python/pyClamd/pyClamd-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..dfcc0c76b5e6
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.4.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -e 's:/etc/clamav/clamd.conf:/etc/clamd.conf:' \
+ -i pyclamd/pyclamd.py || die
+}