summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyaes')
-rw-r--r--dev-python/pyaes/pyaes-1.6.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pyaes/pyaes-1.6.0.ebuild b/dev-python/pyaes/pyaes-1.6.0.ebuild
index 39724be2a32b..839a967746df 100644
--- a/dev-python/pyaes/pyaes-1.6.0.ebuild
+++ b/dev-python/pyaes/pyaes-1.6.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1
@@ -16,4 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPENDS="dev-python/setuptools"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} tests/test-{aes,blockfeeder,util}.py || die
+}