summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/pycparser-2.20.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/pycparser/pycparser-2.20.ebuild b/dev-python/pycparser/pycparser-2.20.ebuild
index 4b222c379ee4..12172c1c82ea 100644
--- a/dev-python/pycparser/pycparser-2.20.ebuild
+++ b/dev-python/pycparser/pycparser-2.20.ebuild
@@ -41,6 +41,8 @@ python_compile() {
}
python_test() {
+ # Skip tests if cpp is not in PATH
+ type -P cpp >/dev/null || return 0
# change workdir to avoid '.' import
cd tests || die
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"