summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydns/pydns-3.2.1.ebuild')
-rw-r--r--dev-python/pydns/pydns-3.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pydns/pydns-3.2.1.ebuild b/dev-python/pydns/pydns-3.2.1.ebuild
new file mode 100644
index 000000000000..2e106c715793
--- /dev/null
+++ b/dev-python/pydns/pydns-3.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/py/py3}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Python DNS (Domain Name System) library"
+HOMEPAGE="https://launchpad.net/py3dns"
+SRC_URI="https://launchpad.net/${MY_PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="CNRI"
+SLOT="3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+# Tests require network access
+RESTRICT="test"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r tests/. tools/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}