summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydocstyle/pydocstyle-6.1.1-r1.ebuild')
-rw-r--r--dev-python/pydocstyle/pydocstyle-6.1.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pydocstyle/pydocstyle-6.1.1-r1.ebuild b/dev-python/pydocstyle/pydocstyle-6.1.1-r1.ebuild
new file mode 100644
index 000000000000..cda0c18fbec7
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-6.1.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="
+ https://github.com/PyCQA/pydocstyle/
+ https://pypi.org/project/pydocstyle/
+"
+SRC_URI="
+ https://github.com/PyCQA/pydocstyle/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/snowballstemmer[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Requires network to lookup github issues
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+PATCHES=(
+ "${FILESDIR}"/pydocstyle-6.1.1-disarm-pip-install.patch
+)