summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r1.ebuild')
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r1.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r1.ebuild
deleted file mode 100644
index 4c3cac2456c5..000000000000
--- a/dev-python/pygame_sdl2/pygame_sdl2-7.3.5-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit distutils-r1
-
-PYSDL="${PN}-2.1.0"
-
-DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
-HOMEPAGE="https://github.com/renpy/pygame_sdl2"
-SRC_URI="https://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1 ZLIB"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]"
-DEPEND="
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- ' -3)
- $(python_gen_cond_dep '
- dev-python/numpy-python2[${PYTHON_USEDEP}]
- ' -2)
- media-libs/libpng:0=
- media-libs/libsdl2:=[video]
- media-libs/sdl2-image:=[png,jpeg]
- >=media-libs/sdl2-mixer-2.0.2:=
- media-libs/sdl2-ttf:=
- virtual/jpeg:0"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
-
-# PyGame distribution for this version has some pregenerated files;
-# we need to remove them
-python_prepare_all() {
- rm -r gen{,3} || die
- distutils-r1_python_prepare_all
-}