summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild')
-rw-r--r--dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild b/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild
index 56110eb0d87b..b2466d83a688 100644
--- a/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild
+++ b/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild
@@ -23,3 +23,11 @@ DEPEND="${RDEPEND}"
distutils_enable_tests unittest
distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_prepare_all() {
+ # We're not interested in linter tests in Gentoo, needs pycodestyle
+ rm unittests/pep8_tester.py || die
+ sed -i -e '/pep8_tester/d' unittests/test_all.py || die
+
+ distutils-r1_python_prepare_all
+}