summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyparted/pyparted-3.10.3-r1.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.10.3-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pyparted/pyparted-3.10.3-r1.ebuild b/dev-python/pyparted/pyparted-3.10.3-r1.ebuild
deleted file mode 100644
index 9272865dd6fc..000000000000
--- a/dev-python/pyparted/pyparted-3.10.3-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for sys-block/parted"
-HOMEPAGE="https://github.com/dcantrell/pyparted/"
-SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="test"
-REQUIRED_USE="
- test? ( python_targets_python2_7 )
-"
-
-RDEPEND="
- >=sys-block/parted-3.1
- dev-python/decorator[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-python/pychecker )
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${PN}-${P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-greater.patch
- "${FILESDIR}"/${P}-sbin-parted.patch
-)
-
-python_test() {
- if [[ ${EPYTHON} = python2* ]]; then
- emake test
- else
- einfo "Skipping ${EPYTHON}"
- fi
-}