summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyphen/pyphen-0.9.5.ebuild')
-rw-r--r--dev-python/pyphen/pyphen-0.9.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyphen/pyphen-0.9.5.ebuild b/dev-python/pyphen/pyphen-0.9.5.ebuild
new file mode 100644
index 000000000000..ea8a50eaa3d8
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.9.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+MY_PN="Pyphen"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="https://github.com/Kozea/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -v test.py || die
+}