summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyquery/pyquery-1.2.9.ebuild')
-rw-r--r--dev-python/pyquery/pyquery-1.2.9.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/pyquery/pyquery-1.2.9.ebuild b/dev-python/pyquery/pyquery-1.2.9.ebuild
index c556f77aa4a..c738f3ac3d2 100644
--- a/dev-python/pyquery/pyquery-1.2.9.ebuild
+++ b/dev-python/pyquery/pyquery-1.2.9.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="A jQuery-like library for python"
HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,22 +15,27 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm ~hppa ppc ppc64 sparc x86"
-IUSE="beautifulsoup3 test"
+IUSE="test"
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
>dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
>=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
app-arch/unzip
test? ( ${RDEPEND}
+ dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+ dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}] )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
python_test() {
# The suite, it appears, requires this hard setting of PYTHONPATH!
PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}