summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrax/pyrax-1.9.4.ebuild')
-rw-r--r--dev-python/pyrax/pyrax-1.9.4.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pyrax/pyrax-1.9.4.ebuild b/dev-python/pyrax/pyrax-1.9.4.ebuild
deleted file mode 100644
index 364b110b6959..000000000000
--- a/dev-python/pyrax/pyrax-1.9.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python language bindings for OpenStack Clouds"
-HOMEPAGE="https://github.com/rackspace/pyrax"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-CDEPEND="
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/python-novaclient-2.13.0[${PYTHON_USEDEP}]
- dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${CDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/rax-scheduled-images-python-novaclient-ext[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_test() {
- nosetests tests/unit || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( samples/. )
-
- distutils-r1_python_install_all
-}