summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrax')
-rw-r--r--dev-python/pyrax/Manifest3
-rw-r--r--dev-python/pyrax/pyrax-1.9.2.ebuild53
-rw-r--r--dev-python/pyrax/pyrax-1.9.3.ebuild52
-rw-r--r--dev-python/pyrax/pyrax-1.9.4.ebuild44
4 files changed, 0 insertions, 152 deletions
diff --git a/dev-python/pyrax/Manifest b/dev-python/pyrax/Manifest
index 5f1e42a70767..97196e10f255 100644
--- a/dev-python/pyrax/Manifest
+++ b/dev-python/pyrax/Manifest
@@ -1,4 +1 @@
-DIST pyrax-1.9.2.tar.gz 311901 SHA256 1971dd941cc750815a0b51d3b0ed6a30cfa9f1dcc562bca808b0708b9ffed8ed SHA512 e095349c42709e5cc382f4d90de2711d6ac53b1d41dd34c3969ed4423f8c5534ff902d78cfae71f6cb7bb4200fd1ab66305ebf43ab03b0c928580b34c06bc1ef WHIRLPOOL eec8a1aa3f99f39f5a461e40e64b23854313ca4ae8a8ef76ab78e103ce4b62a07531f019246a459e65cf6b5a0f67d582f316af3f5ebbec9dbb307a2c589c5182
-DIST pyrax-1.9.3.tar.gz 307959 SHA256 0a3026c67df7bb84720cf562eef0fb15ad67dce79b6fc5e8da46621489be26bb SHA512 8ffb641e46d2f9cda079f619303f92c65fd41cf2ad773c5e8da981257fe9d4aac94e9bc08fab53e3b0a9b63a661381ff7805cbfd34ddef3275cba2d69858aa69 WHIRLPOOL 9060febb5b9d90cea5b248acf73af162df7b4badd66462916fd7e63f875edacde046c83fced1f5f03e500a1ca9d9f74fd746927d1c42942a561d002caa316d3d
-DIST pyrax-1.9.4.tar.gz 312608 SHA256 5cc27688cccd4137a4c53a69b6e0e877054a0bafec899f8170ccc0b58fbf95f3 SHA512 be84e558095a7f76998dd7909cfa5f1ef97a1d65a5a3fe168d70e3978a5974b4eb1592690aac7b0bd52b09faed79fca52006b17e5a22008850088a953d5bef72 WHIRLPOOL ae1c5ae01bbe704404e589a3a1bf1b12abc77817bbdf6e879301dd0716b1f84aa80903ec1d5b4035eacca81221680d8fd44cf0112081a5aff6f4abfbf5973b7d
DIST pyrax-1.9.7.tar.gz 313170 SHA256 6f2e2bbe9d34541db66f5815ee2016a1366a78a5bf518810d4bd81b71a9bc477 SHA512 e83c5e79d49eb3095e8e196b4c9db419194131503d95737564e5a1e3e20f06aa4b53196111d8d326ac50041cd0c2590cefeb41d7d6d654112a85df867b7495f3 WHIRLPOOL a41c5d8ba30b72fd3b07fa43300a8123ed3be93bf4d70db9fd3df3ff90d9415c4dfe895ca2f89457a300f1a738e93b6cd1b0bd0f81edc4ee905bad003f05ec1d
diff --git a/dev-python/pyrax/pyrax-1.9.2.ebuild b/dev-python/pyrax/pyrax-1.9.2.ebuild
deleted file mode 100644
index 9aed8f050b90..000000000000
--- a/dev-python/pyrax/pyrax-1.9.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python language bindings for OpenStack Clouds"
-HOMEPAGE="https://github.com/rackspace/pyrax"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-CDEPEND="
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/python-novaclient-2.13.0[${PYTHON_USEDEP}]
- dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${CDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/rax-scheduled-images-python-novaclient-ext[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_test() {
- ebegin 'patching tests/unit/test_utils.py'
- sed \
- -e '92,100d' \
- -i tests/unit/test_utils.py
- STATUS=$?
- eend ${STATUS}
- [[ ${STATUS} -gt 0 ]] && die
-
- nosetests tests/unit || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( samples/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyrax/pyrax-1.9.3.ebuild b/dev-python/pyrax/pyrax-1.9.3.ebuild
deleted file mode 100644
index a58917da5295..000000000000
--- a/dev-python/pyrax/pyrax-1.9.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python language bindings for OpenStack Clouds"
-HOMEPAGE="https://github.com/rackspace/pyrax"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-CDEPEND="
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/python-novaclient-2.13.0[${PYTHON_USEDEP}]
- dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${CDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/rax-scheduled-images-python-novaclient-ext[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_test() {
- #ebegin 'patching tests/unit/test_utils.py'
- #sed \
- # -e '92,100d' \
- # -i tests/unit/test_utils.py
- #STATUS=$?
- #eend ${STATUS}
- #[[ ${STATUS} -gt 0 ]] && die
-
- nosetests tests/unit || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( samples/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyrax/pyrax-1.9.4.ebuild b/dev-python/pyrax/pyrax-1.9.4.ebuild
deleted file mode 100644
index 364b110b6959..000000000000
--- a/dev-python/pyrax/pyrax-1.9.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python language bindings for OpenStack Clouds"
-HOMEPAGE="https://github.com/rackspace/pyrax"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-CDEPEND="
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/python-novaclient-2.13.0[${PYTHON_USEDEP}]
- dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${CDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/rax-scheduled-images-python-novaclient-ext[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_test() {
- nosetests tests/unit || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( samples/. )
-
- distutils-r1_python_install_all
-}