summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyserial/pyserial-3.5.ebuild')
-rw-r--r--dev-python/pyserial/pyserial-3.5.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/pyserial/pyserial-3.5.ebuild b/dev-python/pyserial/pyserial-3.5.ebuild
deleted file mode 100644
index 793b5b1df0be..000000000000
--- a/dev-python/pyserial/pyserial-3.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Python Serial Port extension"
-HOMEPAGE="https://github.com/pyserial/pyserial https://pypi.org/project/pyserial/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="examples"
-
-DOCS=( CHANGES.rst README.rst )
-
-distutils_enable_sphinx documentation --no-autodoc
-
-python_test() {
- "${EPYTHON}" test/run_all_tests.py loop:// -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}