summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-2.2.1.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.2.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-2.2.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.2.1.ebuild
deleted file mode 100644
index 3eaf9819fc11..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.2.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.python.org/pypi/pytest-cov"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]
- >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- || (
- >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- )
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pytest-capturelog[${PYTHON_USEDEP}]
- )"
-
-# https://github.com/pytest-dev/pytest-cov/issues/99
-RESTRICT=test
-
-python_test() {
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
- PYTEST_PLUGINS=${PN/-/_} \
- py.test -v -v -x || die
-}