summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild')
-rw-r--r--dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild b/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild
deleted file mode 100644
index 01da741b3e65..000000000000
--- a/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pytest plugin that activates the fault handler module for tests"
-HOMEPAGE="https://github.com/pytest-dev/pytest-faulthandler"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-DEPEND="
- >=dev-python/pytest-4.0[${PYTHON_USEDEP}]
- <dev-python/pytest-5.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}