summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild')
-rw-r--r--dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild b/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild
new file mode 100644
index 000000000000..38021a87f44e
--- /dev/null
+++ b/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin that activates the fault handler module for tests"
+HOMEPAGE="https://github.com/pytest-dev/pytest-faulthandler"
+SRC_URI="https://github.com/pytest-dev/pytest-faulthandler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+"