summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-forked/pytest-forked-1.2.0.ebuild')
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.2.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild
index d1217706c9c8..eb87e973a811 100644
--- a/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild
+++ b/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild
@@ -18,12 +18,16 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="
- >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]"
+# Please do not RDEPEND on pytest; this package won't do anything
+# without pytest installed, and there is no reason to force older
+# implementations on pytest.
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]
+ )"
python_test() {
distutils_install_for_testing