summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild')
-rw-r--r--dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild
new file mode 100644
index 000000000000..1adf6a3da22b
--- /dev/null
+++ b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides a helpers pytest namespace"
+HOMEPAGE="
+ https://github.com/saltstack/pytest-helpers-namespace/
+ https://pypi.org/project/pytest-helpers-namespace/
+"
+SRC_URI="
+ https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_helpers_namespace.plugin
+ epytest -p pytest_forked --forked
+}