summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-pep8')
-rw-r--r--dev-python/pytest-pep8/files/1.0.6-MANIFEST.patch9
-rw-r--r--dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild5
2 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/pytest-pep8/files/1.0.6-MANIFEST.patch b/dev-python/pytest-pep8/files/1.0.6-MANIFEST.patch
new file mode 100644
index 000000000000..3e9d2f20dcda
--- /dev/null
+++ b/dev-python/pytest-pep8/files/1.0.6-MANIFEST.patch
@@ -0,0 +1,9 @@
+diff --git a/MANIFEST.in b/MANIFEST.in
+--- a/MANIFEST.in
++++ b/MANIFEST.in
+@@ -4,5 +4,3 @@
+ include tox.ini
+ include LICENSE
+ include test_pep8.py
+-graft doc
+-graft test_pep8.py
diff --git a/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild b/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
index dd03d872fb3c..42c5dafebb6c 100644
--- a/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
+++ b/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
@@ -18,12 +18,17 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pep8-1.3[${PYTHON_USEDEP}]
>=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
dev-python/pytest-cache[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/1.0.6-MANIFEST.patch
+)
+
python_test() {
${EPYTHON} test_pep8.py || die
}