summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild')
-rw-r--r--dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild b/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild
index f44d7562aadf..8d34daccb60b 100644
--- a/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild
+++ b/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
@@ -15,12 +15,12 @@ HOMEPAGE="
"
SRC_URI="
https://github.com/pytest-dev/pytest-services/archive/${PV}.tar.gz
- -> ${P}.tar.gz
+ -> ${P}.gh.tar.gz
"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ~ppc64 ~riscv x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
@@ -34,7 +34,7 @@ BDEPEND="
dev-python/pylibmc[${PYTHON_USEDEP}]
x11-base/xorg-server[xvfb]
net-misc/memcached
- !dev-python/pytest-salt
+ !!dev-python/pytest-salt
)
"
@@ -44,7 +44,3 @@ PATCHES=(
"${FILESDIR}/pytest-services-2.0.1-no-mysql.patch"
"${FILESDIR}/pytest-services-2.0.1-lockdir.patch"
)
-
-python_test() {
- epytest -p no:xvfb
-}