summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild')
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
deleted file mode 100644
index 3f037acb055c..000000000000
--- a/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Write unit tests in Python to test actual state of your servers"
-HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-# Ansible is called via its CLI
-BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- app-admin/ansible
- app-admin/salt[${PYTHON_USEDEP}]
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/pywinrm[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- elog "For the list of available connection back-ends and their dependencies,"
- elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
-}