summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild')
-rw-r--r--dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild b/dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild
new file mode 100644
index 000000000000..c5e588074fd7
--- /dev/null
+++ b/dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="take TDD to a new level with py.test and testmon"
+HOMEPAGE="https://github.com/tarpas/pytest-testmon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+dev-python/coverage[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}