summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild')
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild
deleted file mode 100644
index e81f730b78a4..000000000000
--- a/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
-HOMEPAGE="
- https://github.com/python-trio/pytest-trio
- https://pypi.org/project/pytest-trio/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/trio-0.15[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- dev-python/attrs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinxcontrib-trio
-
-python_prepare_all() {
- # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
- mv pytest_trio/_tests/conftest.py conftest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # disable autoloading pytest-asyncio in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading pytest-trio
- local -x PYTEST_PLUGINS=pytest_trio.plugin
- epytest
-}