summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest2
-rw-r--r--dev-python/pytest/pytest-3.10.1.ebuild71
-rw-r--r--dev-python/pytest/pytest-4.5.0.ebuild70
3 files changed, 0 insertions, 143 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 282e026a5017..ff78a2af9d16 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-3.10.1.tar.gz 892420 BLAKE2B 38849ae69bf4380bc1a99aa105cac04be078da4460373dfc16fa555238b2830fa2f5ae6c19de8aa2af9ac18d87c5d2705d62f7b2e67e4a62d843f6a28bbd76fd SHA512 30ff79c0fdcbeef68e1191ff400a20428e391717f06957f554b694b94baaaa565dca01346fe989c3e443c4402f3b2bdbd5564f6303a4447f933fb54cba45628f
-DIST pytest-4.5.0.tar.gz 943607 BLAKE2B 49a0e91fda7f4231fdd39f90eb2daa344d3034c10faff221330ea0ae7482a2a7d0fb9443a0a264db00f1d92568d5a6005cb73e07d8643b46906f7ecff831adcb SHA512 cbffc6216f83491b1de241058315c116697bfaa5206b5f558192a7f861d43dd036d30d0d689bedae7bdee4f0258dd19ef5827c356e11863dd596a5fabe8249fc
DIST pytest-4.6.11.tar.gz 952305 BLAKE2B af07adf5e8fc614b1fdb7b5673fb9c557ff0dd3f22e2f3bf853c643c5c8bd38f307018579299b700d90034a826db73a3e569857d6d6f7ac6646ace894b35a39b SHA512 6fddf4944bd9fab83024aa2d338d54aaf3d164bd5c7f634357376f3b0d2dab6a43d784e7fb567236c2d2f029151c5d9e2cb36c22e9b551c2c8823c52a2246e9c
DIST pytest-5.4.3.tar.gz 1022353 BLAKE2B 70d4f23cbbfc4c4ce63c512ee0a01556973761a6d3ebb71a6d9ed4fb4a4a21531e1b151ed0e4c5e56e5dd3243a1a272441f17c4c2c4e3b0b19c24654b74e8e52 SHA512 0a07d4f4f791969c6f21961a0ba0f8c6670e5870c6cc1cebf93766587bb9cb3e10db8e57f0bd33dd22b275f3aad7aa674949f124ac80e0ccca64e35be4beee4e
DIST pytest-6.0.1.tar.gz 1069631 BLAKE2B 89a78ebf8e8cf968ea767fe7244408ca79d247c1ca459815ac299ce773b44c375429935c8a25b4de26349969113c60e4b6812d5aa2d805691664af74796ea85b SHA512 bdd790c3860da2ed3a3ff47f04512c3bfae4fa1e31fc6b96fc19bd57d1804a6fec968ecf17a11c5b20d30dcf82d6391ef0d893ae57a3da9ad777a15c078c129f
diff --git a/dev-python/pytest/pytest-3.10.1.ebuild b/dev-python/pytest/pytest-3.10.1.ebuild
deleted file mode 100644
index d6514cfaade9..000000000000
--- a/dev-python/pytest/pytest-3.10.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="https://pytest.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.5.0"
-
-# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
-# support, which only came in py3.6.
-RDEPEND="
- >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- <dev-python/more-itertools-6.0.0[${PYTHON_USEDEP}]
- dev-python/funcsigs[${PYTHON_USEDEP}]
- dev-python/pathlib2[${PYTHON_USEDEP}]
- ' -2)
- $(python_gen_cond_dep '>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]' python3_{6,7} pypy{,3} )
- >=dev-python/pluggy-0.7[${PYTHON_USEDEP}]
- >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
- >=dev-python/setuptools-40[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-
-# flake & pytest-capturelog cause a number of tests to fail
-DEPEND="${RDEPEND}
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
- dev-python/requests[${PYTHON_USEDEP}]
- !!dev-python/flaky
- !!dev-python/pytest-capturelog
- !!<dev-python/pytest-xdist-1.22
- )"
-
-python_prepare_all() {
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
- # Something in the ebuild environment causes this to hang/error.
- # https://bugs.gentoo.org/598442
- rm testing/test_pdb.py || die
-
- # those tests appear to hang with python3.5+; TODO: investigate why
- sed -i -e 's:test_runtest_location_shown_before_test_starts:_&:' \
- testing/test_terminal.py || die
- sed -i -e 's:test_trial_pdb:_&:' testing/test_unittest.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
- -vv testing || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/pytest/pytest-4.5.0.ebuild b/dev-python/pytest/pytest-4.5.0.ebuild
deleted file mode 100644
index b7645ac3a2c7..000000000000
--- a/dev-python/pytest/pytest-4.5.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="https://pytest.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.5.0"
-
-# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
-# support, which only came in py3.6.
-RDEPEND="
- >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pathlib2[${PYTHON_USEDEP}]
- dev-python/funcsigs[${PYTHON_USEDEP}]
- ' -2)
- >=dev-python/pluggy-0.11[${PYTHON_USEDEP}]
- <dev-python/pluggy-1
- >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
- >=dev-python/setuptools-40[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]"
-
-# flake cause a number of tests to fail
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
- dev-python/requests[${PYTHON_USEDEP}]
- !!dev-python/flaky
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.5.0-strip-setuptools_scm.patch"
-)
-
-python_prepare_all() {
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
- # Something in the ebuild environment causes this to hang/error.
- # https://bugs.gentoo.org/598442
- rm testing/test_pdb.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # In v4.1.1, pytest started being picky about its own verbosity options.
- # running pytest on itself with -vv made 3 tests fail. This is why we don't
- # have it below.
- "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
- || die "tests failed with ${EPYTHON}"
-}