summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-5.3.2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 65e0fcecc4d1..84d8b5fd2bf0 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -4,3 +4,4 @@ DIST pytest-4.6.6.tar.gz 954899 BLAKE2B d3d76ec1fff18d343cc799f1acd0889489f303cd
DIST pytest-4.6.7.tar.gz 955616 BLAKE2B eb2276e715bab176fe4e497a51779d82b7146704749b33ebdc9dc07a0fcad144252553280a7bbbbcf23c6862fb74f1faf75de42ed0f5295ecd287fc10ac287a0 SHA512 d284cef48c0e39c901d23cd63949cc1d8b8cf01c3039fd2bfd99275bf6a45532c955e1176d556a7e2198e6206830e6dc4f4fb22c143ff7e08de6ffbfb6079fd1
DIST pytest-5.3.0.tar.gz 992537 BLAKE2B 4386d1623bdc168313a75847dfa33413ab1b6a4de9380c67ae866a579dbeb62d8cd18da899bf0476827d6e4a76ddfc5fee7a2fdc652eff0c8848c0bd96045c47 SHA512 285d0b4f6b87b141d6d5dac368dc46eb80dd025d7ed4ad0db937fcc76efc1f8cf251ca9b0786ab1bdadd89c07ad8ddd74f2b3496f97326e9d7fccfd004b98aff
DIST pytest-5.3.1.tar.gz 994584 BLAKE2B 3831902684d935389b4684af1279a5834edbbe846f8fdb1ce1e64990ab65d6fe8ed3cf5daa446cd20daafe9eedc6f57e01b16d74a55631ab746750a73056640d SHA512 e949a516c064a7050a0ad15356cc0bf25e4840e830f03e1925530c8a2dd9903d7632e55535894474422ba86fd9ed7a397c483d98dad297990b7b49456147189e
+DIST pytest-5.3.2.tar.gz 995560 BLAKE2B aaea9d89e884a82056eeea3068c70604c73d50c96b8d78c6ee14c67bbe066f0e6d882c1b8f95539a2338d6739e047680d901a9db108b1923fa4d3d03dc3f2115 SHA512 2ab39973848d2d4693edd1dbd7ab2798b574026c9277bddd4a18e57aec65b3d93de201e87f58eb26030183b5c71818e6e56bcc1cda8c50892546cb1c04d6984a
diff --git a/dev-python/pytest/pytest-5.3.2.ebuild b/dev-python/pytest/pytest-5.3.2.ebuild
new file mode 100644
index 000000000000..76a95d4f3d73
--- /dev/null
+++ b/dev-python/pytest/pytest-5.3.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="https://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+RDEPEND="
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_5 )
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# flake cause a number of tests to fail
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-40[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-4.5.0-strip-setuptools_scm.patch
+)
+
+python_prepare_all() {
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" -m pytest -vv --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
+}